www.xdqh.net > 在uBuntu下安装qt4.2时,mAkE时出现 pArsEr.h:27:1...

在uBuntu下安装qt4.2时,mAkE时出现 pArsEr.h:27:1...

看下/usr/local/qt-x11-opensource-src-4.2.0/src/tools/moc/moc.h:27 引用的这个文件在哪里,能找到的话复制过来. 要是实在解决不了,也找不到的话改下上一级的makefile,让他不编译这个目录.有时候有的目录用不上,不编译也行

一个一个安装,把要的都装上,apt-get install gcc等.(先su).

清空一下make confclean,再重新configure一次

在Ubuntu下安装Qt报错的解决办法 为什么要自己下载安装呢使用包管理器安装又方便又好用何必要找麻烦从官网下载安装呢如果确实有必要自己从官网下载安装的话那就另当别论了首先检查下libHelp.so的文件是不是有错误(主要看它是不是一

Ubuntu安装软件基本式软件源网站或者镜像网站直接载安装

你的mingw版本冲突吧,-fno-keep-inline-dllexport需要g++ >=4.6.开个cmd查一下你的 g++的版本吧.

这不是 QT 的错误信息,是 GTK 2.0 的输出信息,一般情况下可以无视.很多 GTK 程序只要一运行就狂输出到 stdout .一般图形界面反正也不用命令行,眼不见心就不烦了.

应该是路径设置问题,百度了一下,仅供参考export QTDIR="/home/qt/qt-2.3.2"export QT

这种问题解决方法如下:执行sudo apt-get install libXrender-dev命令,安装相应的lib文件.所以最好在编译Qt原码前先执行以下命令: sudo apt-get install libglib2.0-dev libSM-dev libxrender-dev libfontconfig1-dev libxext-dev sudo apt-get install

楼主,我也出现你一样的问题啊!!待解救啊!

相关搜索:

网站地图

All rights reserved Powered by www.xdqh.net

copyright ©right 2010-2021。
www.xdqh.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com